[gmx-users] Integrating with BOINC: failing at minimization

Jack Shultz jshultz at hydrogenathome.org
Thu Mar 26 21:30:36 CET 2009


I've tried a couple ways of running the workshop tutorial with a
different protein and amber03 force field. It works with a clean
install of gromacs, but I am trying to integrate it into a grid
computing project.

I tried several approaches to running this app but encountered a
strange problem in both approaches to integrating. It always has
trouble minimizing. This indicates to me, there is something strange
with the environment that I created. If you have any hints for me that
would be great. The two approaches I tried were:
1) putting all the dependent files in the same directory as the binary
and executing it, this failed when I tested it stand alone and it
created this same error
2) I tried writing a bash script to mimics the GMXRC.bash except it
maps every directory relative to a temporary directory where
everything runs. (e.g. GMXBIN=../slot/0/bin/)
It seems to run fine through a workunit but then it does not minimize
properly causing additional problems downstream

Steepest Descents converged to machine precision in 54 steps,
but did not reach the requested Fmax < 10.
Potential Energy  = -8.35030867755191e+214
Maximum force     = 7.83437759695905e+221 on atom 25439
Norm of force     = 5.13628303396235e+219




More information about the gromacs.org_gmx-users mailing list