[gmx-users] grompp segfault

Mark Abraham Mark.Abraham at anu.edu.au
Wed Oct 28 23:07:58 CET 2009

Birger Dittrich wrote:
> Dear Gromacs users,
> I have compiled gromacs 4.0.5 on a suse 10.3 x86-64 box
> after having compiled and installed fftw-3.2.2 and encountered
> no problems.
> Now I would like to check whether the installation has
> worked ok.
> I downloaded the gmxtest test suite, unpacked it in the gromacs directory
> and tried to run it after sourcing GMXRC. However, the test suite fails.

Don't bother - it's barely a useful test for GROMACS 4. I did some work 
improving it a few months back 
which is in the git version, but apparently there were too many 
outstanding issues for anybody else to be interested in working towards 
releasing a version that did work reliably for GROMACS 4. It's 
unfortunate that there is all this documentation suggesting using it and 
it doesn't work. :-(

> The output I get is
> (~/gromacs-4.0.5): grompp -h
>                          :-)  G  R  O  M  A  C  S  (-:
> Segmentation fault
> Has anybody got a clue what I can try to
> do to get the grompp running or how I can get more information
> on the possible cause for the segfault?

This failure is not related to the test suite, of course. I'd guess you 
have some problem with dynamic linking of libraries - they were present 
in relevant library paths when you configured, and are not now.


More information about the gromacs.org_gmx-users mailing list