[gmx-users] Re: Simulation of a protein in a water/DMSO box

Justin A. Lemkul jalemkul at vt.edu
Wed Sep 30 14:07:42 CEST 2009

Simone Cirri wrote:
> Justin A. Lemkul wrote:
>     Simone Cirri wrote:
>     Hi everyone,
>     I need to run a simulation of a protein in a water/DMSO mixture. I
>     can't quite understand how should I do this... should I normally
>     solvate the protein with water and then replace a certain number of
>     water molecules (according to the needed % of DMSO) with DMSO
>     molecules? But in this case, how should I do it? Is there a way of
>     replacing solvent molecules with other solvent molecules, but of a
>     different type?
>     I'm sorry but I don't know which procedure to follow.
>     Thanks in advance
>     The easiest way I can think of is to define the box around your
>     protein, use genbox -ci -nmol to insert the desired number of DMSO
>     molecules, and then fill the box with water. You may have to tweak
>     the box size or use genbox -maxsol to get the desired concentration.
> Hi Justin, I've tried your method. More or less, it works: I manage to 
> insert the exact desired number of DMSO molecules, and when I fill the 
> box with water, I get slightly less molecules that the ones I 
> calculated, but I think I can ignore that.
> The problem comes with grompp, because I get the error:
> Fatal error:
> number of coordinates in coordinate file (1JIC_dmso_water.gro, 17314)
>              does not match topology (1JIC.top, 16454)
> because, evidently, the .top file does not contain any trace of the 215 
> DMSO molecules I added (215 x 4 = 860, which is the difference of 
> coordinates between the .gro file and the .top file).

Right, because you need to add these molecules to the [molecules] directive in 
your .top.

> I tried to add a line:
> #include "dmso.itp"
> but I get another fatal error:
> Fatal error:
> Atomtype SD not found
> due to the fact that I'm using the AMBER99 forcefield. In fact, this 
> forcefield (as I've seen in the .atp file) only contains 2 types of S:
> S (sulphur in disulfide linkage)
> SH (sulphur in cystine)
> and I guess that none of them is the right one... so I don't think I can 
> simply rename the SD in the dmso.itp file to S, for example.
> How should I solve the problem, then?

The dmso.itp file is for use with the deprecated ffgmx force field.  There are 
good parameters in the literature for Gromos96 53a6, and perhaps others.  You 
will have to find suitable parameters for DMSO that are compatible with Amber99. 
  They may exist somewhere, but if not, you have to derive them yourself, which 
is not an easy task.


> Thank you very much
> Simone Cirri
> simonecirri at gmail.com <mailto:simonecirri at gmail.com>
> ------------------------------------------------------------------------
> _______________________________________________
> gmx-users mailing list    gmx-users at gromacs.org
> http://lists.gromacs.org/mailman/listinfo/gmx-users
> Please search the archive at http://www.gromacs.org/search before posting!
> Please don't post (un)subscribe requests to the list. Use the 
> www interface or send it to gmx-users-request at gromacs.org.
> Can't post? Read http://www.gromacs.org/mailing_lists/users.php


Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list