[gmx-users] compiling GPU 4.5b2, CUDA_INCLUDE_DIRECTORIES function is undefined

chris.neale at utoronto.ca chris.neale at utoronto.ca
Wed Aug 4 16:38:52 CEST 2010

Dear Szilárd and Rossen:

I have attempted with gcc4.4.0 and I got the same result. I can verify  
that cmale/FindCUDA.cmake exists and contains the MARCO for  
CUDA_INCLUDE_DIRECTORIES but it seems that this library is not, for  
some reason, getting loaded in by at least  
kernel/gmx_gpu_utils/CMakeLists.txt because if I add that macro to  
that file then the error disappears.

Thank you,

## what I did:

module purge
module load gcc/gcc-4.4.0
module load cmake/2.8.0  #need version >=2.6.4
module load cuda/cuda-3.1
mkdir gpuexec
cmake /project/pomes/cneale/GPC/exe/intel/gromacs-4.5-beta2/src  
-DCMAKE_INSTALL_PREFIX=$(pwd)/gpuexec -DLIB_INSTALL_DIR=$(pwd)/gpuexec

## output

CMake Error at kernel/gmx_gpu_utils/CMakeLists.txt:18  
   Unknown CMake command "CUDA_INCLUDE_DIRECTORIES".

CMake Warning (dev) in CMakeLists.txt:
   No cmake_minimum_required command is present.  A line of code such as

     cmake_minimum_required(VERSION 2.8)

   should be added at the top of the file.  The version specified may be lower
   if you wish to support older CMake versions for this project.  For more
   information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

PS I also tried without -DCMAKE_INSTALL_PREFIX=$(pwd)/gpuexec  
-DLIB_INSTALL_DIR=$(pwd)/gpuexec and got the same thing.

Also, sorry for the repost, I was trying to change the subject line to  
something more representative.


-- original message --

Hi Chris,

Though I'm repeating myself, for the sake of not leaving this post
unanaswered (btw reposts should be avoided as much as possible!):

First of all, as Rossen said, the <=2.6.4 is a typo, it was meant to
be >=2.6.4, it _should_ work with 2.8.0 (I took the FindCUDA.cmake
script from the 2.8 cmake sources :), but...

icc is _not_ supported by CUDA, AFAIR some people reported getting it
work but only in some very limited special cases.

Could you try with gcc and see if it works? Please get back to us if  
it doesn't!


On Wed, Aug 4, 2010 at 12:38 AM,  <chris.neale at utoronto.ca> wrote:
> Thanks Rossen, I did not yet get it working. I just posted under a more
> relevant title, please see the post:
> http://lists.gromacs.org/pipermail/gmx-users/2010-August/052939.html
> (there were 2 errors, one that I fixed and one that I am still struggling
> with).
> Chris.
> -- original message --
> Actually this was a mistake on the website, it must be CMake >= 2.6.4,
> so 2.8.0 is fine. Although the build system requires CUDA 3.1, that
> doesn't seem to be the problem from your log.
> Did you get it to work?
> Rossen

More information about the gromacs.org_gmx-users mailing list