[gmx-users] gmx 4.5 and openmm on Mac, still not compiling

Alan alanwilter at gmail.com
Tue Aug 24 09:49:38 CEST 2010

Hi there,

I've tried before and the error still basically the same (line error in
'nb_kernel400_x86_64_sse.c' was 630, now's 629) .

I am using gmx 4.5 release-4-5-patches branch.

git pull
rm -fr build
mkdir -p build
cd build
make clean
make -j 2
sudo make install # all fine till here
make clean
export OPENMM_ROOT_DIR=/usr/local/openmm
make mdrun

[ 56%] Building C object src/gmxlib/CMakeFiles/gmx.dir/version.c.o
[ 56%] Building C object
In function ‘nb_kernel400nf_x86_64_sse’:
error: ‘gmx_invsqrt_exptab’ undeclared (first use in this function)
error: (Each undeclared identifier is reported only once
error: for each function it appears in.)
error: ‘gmx_invsqrt_fracttab’ undeclared (first use in this function)
make[3]: ***
Error 1
make[2]: *** [src/gmxlib/CMakeFiles/gmx.dir/all] Error 2
make[1]: *** [src/kernel/CMakeFiles/mdrun.dir/rule] Error 2
make: *** [mdrun] Error 2

Any help would be appreciated.


Alan Wilter S. da Silva, D.Sc. - CCPN Research Associate
Department of Biochemistry, University of Cambridge.
80 Tennis Court Road, Cambridge CB2 1GA, UK.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100824/79afbe3e/attachment.html>

More information about the gromacs.org_gmx-users mailing list