[gmx-users] Compiling 4.0.7 parallel fails

Jussi Lehtola jussi.lehtola at helsinki.fi
Sat Feb 6 01:17:35 CET 2010

On Fri, 2010-02-05 at 15:29 -0500, Matthew L. Danielson wrote:
> Compiling fftw and openmpi seems to finish successfully.  The serial 
> version of gromacs installed correctly, just when i issue --enable-mpi i 
> am seeing this error message (i can attached the config.log if it would 
> help):
> "checking size of int... configure: error: cannot compute sizeof (int)"
>  From what i can get out of the mail-archive, I think this is  problem 
> with the mpi installation or not finding the correct files etc.  I have 
> tried re-installing openmpi (always removing the old version) using yum 
> (installed version 1.3.2) and installing openmpi from their website 
> (1.4.1).  Both seem to install correctly, yet the same error message 
> arises when i do ./configure --enable-mpi for gromacs.

What distribution are you using? If you are running Fedora 12, you need
to load the MPI environment module with e.g.
 $ module load openmpi-x86_64

Furthermore, you should have the fftw-devel and openmpi-devel packages
installed on your system.
Jussi Lehtola, FM, Tohtorikoulutettava
Fysiikan laitos, Helsingin Yliopisto
jussi.lehtola at helsinki.fi, p. 191 50632
Mr. Jussi Lehtola, M. Sc., Doctoral Student
Department of Physics, University of Helsinki, Finland
jussi.lehtola at helsinki.fi

More information about the gromacs.org_gmx-users mailing list