[gmx-users] Errors with g_dielectric

Florian Dommert dommert at icp.uni-stuttgart.de
Tue Jul 27 09:08:36 CEST 2010


 have you tried g_current ? It also calculates the dielectric constant.


On 27.07.10 02:36, Jennifer Casey wrote:
> Hello,
> I am trying to calculate the dielectric constant for pure
> tetrahydrofuran (THF) at 298K.  I keep running into problems though. 
> I have looked through the gmx user list to see if others have had
> these problems, but I didn't see any mention of them (although I did
> see that others were asked to report issues with g_dipoles to bugzilla).
> The first thing I do is run g_dipoles using the command (I do this in
> order to get the ACF to use in g_dielectric):
> g_dipoles -f nvt10ns.xtc -s previous.tpr -corr mol -mu 1.75
> *I would have liked to attach the tpr and xtc file, but the message
> was too big.  I can send them if they will help*
> When I do this, I get the following output to terminal:
> There are 255 molecules in the selection
> Using volume from topology:  34.3361 nm^3
> Last Frame 30000 time 12000.001
> t0 0, t 12000, teller 30001
> **then there is a long pause (approx 5 minutes)**
> Dipole Moment (Debye)
> ______________________
> Average = 1.9194     Std. Dev.  = 0.0085     Error = 0.0000
> **Then it lists the different dipole moments, kirkwood factors, and
> finally an epsilon = 4.47756**
> (I cannot attach the output files since they too make this e-mail too
> big.  I will send them if requested.)
> It seems that the g_dipoles is working fine for me.
> Once I have the autocorrelation function (dipcorr.xvg), I want to use
> g_dielectric.  Before I talk about the problems I have here, I wanted
> to verify a few things about the various options:
> epsRF - the default here is 78.5, even though the default in g_dipoles
> is 0 (infinity).  I wanted it to be infinity, so I assume I change it.
> eps0 - this is the epsilon of my liquid - but is it the epsilon that
> was calculated from g_dipoles (4.47756)?
> When I run the command:
> g_dielectric -f dipcorr.xvg -epsRF 0 -d -o -c
> I get a segmentation fault before anything happens:
> Read data set containing 2 columns and 15001 rows
> Assuming (from data) that timestep is 0.4, nxtail = 1249
> Creating standard deviation numbers ...
> nbegin = 13, x[nbegin] = 5.2, tbegin = 5
> Segmentation Fault
> If I leave out the -epsRF, I still get the same error.  If I include
> eps0, I still get a segmentation fault.  It seems strange to me since
> GROMACS generates the input and yet has an issue with it.
> I would like to point out that the manual states to use dipcorr.xvg to
> get the dielectric constant, but after reading the paper GROMACS
> references, it seems that <Mtot^2> is more appropriate. I tried
> running the command g_dielectric -f  Mtot.xvg, and the segmentation
> fault went away.  Instead lambda went to infinity and there was a
> fatal error (nparm = 0 in the file ../../../../src/tools/exptfit.
> c, line 466.
> I am probably missing something obvious, but I am having a hard time
> figuring out what it is.  I appreciate any help.
> Thank you for your time,
> Jenny

Florian Dommert
Dipl. Phys.

Institute for Computational Physics
University Stuttgart

Pfaffenwaldring 27
70565 Stuttgart


Tel: +49 - 711 / 6856-3613
Fax: +49 - 711 / 6856-3658

EMail: dommert at icp.uni-stuttgart.de
Home: http://www.icp.uni-stuttgart.de/~icp/Florian_Dommert

!! PGP-ENCODED emails preferred !!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 259 bytes
Desc: OpenPGP digital signature
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100727/0d710ff7/attachment.sig>

More information about the gromacs.org_gmx-users mailing list