[gmx-users] Problem with PME + test particle insertion

Kevin Daly kdaly at princeton.edu
Fri Oct 8 09:35:30 CEST 2010

Hello Gromacs users,

Recently I ran some test particle insertion simulations of TIP4P/2005
water to measure  the chemical potential at 470 K and 0.861 g/cc. I
found that the chemical potential was  20%-25% higher than literature
values. I believe there may be a problem related to using PME with
test-particle insertion.

To test the PME code, I ran a very short TPI run of a water
configuration with one molecule deleted. I forced insertions into the
hole by using "tpic" mode. I compared the potential energies of these
insertions with those obtained by simply taking the difference in
potential energy of two md runs, where one contains the missing
molecule and one has a hole instead. I ran mdrun in with the "-debug
1" option and added a line of code to tpi.c to print out the insertion
locations. I am running the "release-4-5-patches
origin/release-4-5-patches branch" of Gromacs 4.5.1.

The LJ and short-range coulomb energies agree well, but the long-range
coulomb energy does not. Compare 0.0229272 kJ/mol in TPI mode with
-8.771680 kJ/mol in MD mode. Note that the total energy changes are
-61.19020 and -69.97481, respectively.

Input files for these tests can be found at
http://bugzilla.gromacs.org/show_bug.cgi?id=590 .


More information about the gromacs.org_gmx-users mailing list