[gmx-users] Re: Segmantation fault at g_traj

Susanne Fritz susanne.fritz at chemie.tu-freiberg.de
Wed Oct 13 17:03:29 CEST 2010

Dear All,

I think I have the same problem as Jorge Alberto Jover Galtier recently. 
Since I haven't found any solution within the archive, I try asking again.

If I try to get the atom coordinates from a trajectory file with g_traj, 
g_traj exits with segmentation fault and the generated .xvg file is 
This always happens. It dosn't matter if the trajectory is big or small 
or if I extract coordinates for one or thousands of atoms or timesteps. 
It is even independent from the input file (.trr, .xtc, .gro). It 
happens on different machines and independently from the actual memory 
in use. And it is not a problem with the trajectory (checked with 
gmxcheck, vmd and trjconv).
It only seems to be a problem with the newer version of g_traj. I 
recently switched from gmx 4.0.7 to 4.5.1. If I use a .gro, .mdp and 
.xtc file from a gmx 4.5.1 simulation and generate an "old" run input 
file with gmx 4.0.7, I can get the coordinates with g_traj (4.0.7) 
without problems.
The segmentation fault always occurs when g_traj "has finished". For 
example: for the same trajectory, when I extract 100 or 200 timesteps 
there are always the last two timesteps missing in the .xvg-file. Giving 
the command >g_traj -f -s -ox repeatedly leads to .xvg-files stopping at 
approximately but not exactly the same position.

Since the new gromacs version runs much more efficient on our system and 
g_traj is very important for my simulations, I would be very very 
grateful for any help!

best regards,

additional information:
gmx 4.5.1 was compiled with gcc 4.5 and fftw3 (according to the 
suggested installation procedure) on coreI7 and Athlon64 machines, 
running with suse 11.3 (64 bit).

Jorge Alberto Jover Galtier wrote:
 > Dear friends:
 > Running several simulations, we have found a problem with the 'g_traj'
 > utility. It doesn't finish properly the files it generates, and gives a
 > segmentation fault. This is what we have done:
 > We are working with double precision. With the file .mdp that is at the
 > end of the mail, we have used 'grompp_d' to generate the .tpr file:
 > grompp_d -maxwarn 1000 -f temp_prueba_mail-list_001_mdpmdp -c
 > ../data/in/pep_ini.gro -r ../data/in/pep_ini.gro -p ../data/in/pep.top
 > -o temp_prueba_mail-list_001_tpr.tpr
 > After that, we ran the simulation with 'mdrun_d':
 > mdrun_d -s temp_prueba_mail-list_001_tpr.tpr -o
 > temp_prueba_mail-list_001_trr.trr -c
 > ../data/out/gro_unconstr_1.00_000001.gro -g
 > ../data/out/log_unconstr_1.00_000001.log -e
 > temp_prueba_mail-list_001_edr.edr
 > Then we tried to get the coordinates of the atoms with 'g_traj_d':
 > g_traj_d -f temp_prueba_mail-list_001_trr.trr -s
 > temp_prueba_mail-list_001_tpr.tpr -ox temp_prueba_mail-list_001_ox.xvg
 > At the terminal, we tell the program to get the coordinates from the
 > group 0 (system), although the error appears also for other groups.
 > Here is where the problem appears. When the program is about to finish,
 > it makes segmentation fault and ends abruptly. The .xvg file has only
 > some of the last lines missing, but those are the lines we are
 > interested in. We have tried different ways: we have used different
 > number of steps, we have get velocities and forces instead of
 > coordinates... and always the same problem appears.
 > We would be very thankful if someone could tell us what is going wrong.

More information about the gromacs.org_gmx-users mailing list