[gmx-users] Newest version of Gromacs 4.5 installation

Moeed lecielll at googlemail.com
Wed Sep 1 22:43:28 CEST 2010


We are installing the newest version of Gromacs - 4.5 on our cluster
(running CentOS) for parallel purposes. We are also using Openmpi version
1.4. However upon installing Gromacs using the command:

./configure --enable-mpi

we ran into this problem below:

* Seems you are compiling with MPI support. You can install the MPI-
  enabled programs with suffixed names to have both MPI and non-MPI
  versions. This is useful e.g. on supercomputers where you usually
  cannot run MPI-linked programs on the login node.
  Set a suffix with e.g. --program-suffix=_mpi (or _mpi_d for double).
  You only need MPI for mdrun, so if you already have non-MPI stuff
  installed you can issue make mdrun; make install-mdrun.

  There are known problems with some MPI implementations:
             OpenMPI version < 1.4.1
             MVAPICH2 version <= 1.4.1

* On most platforms you can save 10X space with dynamic libraries, although
  the binaries might be less portable. Why not try --enable-shared ?

Does this imply that we must update our current Openmpi version from 1.4 to
1.41 in order for Gromacs to be installed? Also, what are the pros and cons
of using '--enable-shared'?

Thank you for your help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100901/b41a873d/attachment.html>

More information about the gromacs.org_gmx-users mailing list