[gmx-users] Restarts: Truncation of file *.xtc failed

Yongchul Chung yxc169 at case.edu
Tue Sep 7 19:57:18 CEST 2010


How big is your file? I assume since you are running 180000ps simulation, it
might be big. I remember there's a problem with gromacs not being able to
truncate file size >4Gb.


On Tue, Sep 7, 2010 at 8:04 AM, David de Sancho <daviddesancho at gmail.com>wrote:

> Dear Gromacs users
> I am experiencing a problem with restarts in a REMD simulation with
> explicit solvent in Gromacs 4.0.5. I am trying to continue a set of
> simulations that finished after the maximum time in our cluster queue had
> been reached. Therefore I just directly (i.e. without modifying my input
> file with tpbconv) try continuing my run using
> mpiexec "bindir"/mdrun_openmpi_intel -multi 32 -replex 5000 -v -s
> tprfile.tpr -x xtcfile.xtc -o trrfile.trr  -c grofile.gro -e enefile.ene -g
> logfile.log -cpi cptfile.cpt -cpo cptfile.cpt -append
> This has worked before in previous continuations of this REMD simulation,
> so in principle the pbs script I am using should be fine. However, now I
> find two types of error messages:
> (1) Reading checkpoint file cptfile{i}.cpt generated: ***
> #PME-nodes mismatch,
> current program: -1
>  checkpoint file: 0
> Gromacs binary or parallel settings not identical to previous run.
> Continuation is exact, but is not guaranteed to be binary identical.
> (2) Fatal error:
> Truncation of file xtcfile${i}.xtc failed.
> I have been browsing the lists and apparently the first problem is not very
> important. However the second error, reached after loading the tpr and cpt
> files, is fatal. I have thus checked what the problem was with my xtc files
> by running gmxcheck on them and obtained messages like
> # Atoms  6950
> Precision 0.001 (nm)
> Reading frame   90000 time 180000.016
> Item        #frames Timestep (ps)
> Step         90878    2
> Time         90878    2
> Lambda           0
> Coords       90878    2
> Velocities       0
> Forces           0
> Box          90878    2
> Nothing here tells me much about what can be going wrong. Also, I have
> looked at the last frame of the simulation using vmd in case there were
> missing atoms in my protein but it definitely looks like there is nothing
> wrong. I have tried with the cpt and prev.cpt files in case there was
> something wrong with the cpt file but still I got the fatal error.
> Any hints on what it is that I am doing wrong?
> Thanks
> David
> --
> gmx-users mailing list    gmx-users at gromacs.org
> http://lists.gromacs.org/mailman/listinfo/gmx-users
> Please search the archive at
> http://www.gromacs.org/Support/Mailing_Lists/Search before posting!
> Please don't post (un)subscribe requests to the list. Use the
> www interface or send it to gmx-users-request at gromacs.org.
> Can't post? Read http://www.gromacs.org/Support/Mailing_Lists
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100907/c4925bca/attachment.html>

More information about the gromacs.org_gmx-users mailing list