[gmx-users] Re: Fwd: pdb2gmx problem recognising capping on Gromacs 4.5.2

Justin A. Lemkul jalemkul at vt.edu
Sat Mar 19 18:48:21 CET 2011

Olujide Olubiyi wrote:
> Hello Justin Lemkul,
> Thanks for the other time, for your assistance with a problem I was having concerning
> umbrella sampling. 
> I tried submitting this mail to the users' forum but I got a reply saying I'm not allowed
> to send it. I don't know what that is about. But I have decided to forward the mail to 
> you that you might be able to help clarify it.

You have to be a subscribing member in order to post to the list.  Please ensure 
that your current email address is properly subscribed.  I am not a private 
tutor, so I am CC'ing this message to the list and I would ask that all further 
discussion be posted there.

A few tips:

1. Upgrade to Gromacs 4.5.3 and try again.  No one is usually interested in 
troubleshooting old versions.

2. There is no such thing as gromos43a1.ff/residuetypes.dat, so if you're 
creating or modifying some such file, it will have no effect.  You should have 
residuetypes.dat in $GMXLIB or your working directory for it to work properly. 
It is also possible that you haven't created a proper entry, but you haven't 
provided that information.

3. Your pdb2gmx command line, choices of anything for which you are prompted, 
and the actual error message that you're getting would be useful (read: necessary).


> Thanks a lot.
> 'Jide Olubiyi
> ------------------------------------------------------------------------
> Subject:
> pdb2gmx problem recognising capping on Gromacs 4.5.2
> From:
> Olujide Olubiyi <o.olubiyi at grs-sim.de>
> Date:
> Sat, 19 Mar 2011 16:45:35 +0100
> To:
> gmx-users at gromacs.org
> To:
> gmx-users at gromacs.org
> Dear Gromacs user,
> I am trying to set alanine dipeptide up on Gromacs 4.5.2 but I am having problems doing this.
> The coordinate is composed of ACE-ALA-NME, where ACE is acetyl capping (N-terminus), and NME 
> is N-methyl capping (C-terminus). I was able to perform the simulation successfully on Gromacs
> 4.0.7 after I defined a topology for the NME in ffG43a1 (the forcefield I am using) and updated
> the aminoacids.dat. However, I tried to repeat the same study on Gromacs 4.5.2 and couldn't get
> past pdb2gmx even after I made the necessary changes to /top/gromos43a1.ff/residuetypes.dat and
> top/gromos43a1.ff/aminoacids.rtp. It is as if the new release does not recognised non-standard
> residue definition in the aminoacids.rtp file seeing it gave no complaint about ACE; just NME.
> I searched the archives for similar reporting noticed how Justin Lemkul suspected this might be 
> a bug in the new Gromacs releases. I am wondering if someone finally found a way round this problem
> and will be willing to share the experience. I will be grateful for it. 
> When I skipped the pdb2gmx step by supplying the topol.top file generated with Gromacs 4.0.7 the
> simulation went smoothly. 
> Best regards,
> 'Jide Olubiyi
> German Research School for Simulation Sciences/
> Institute of Complex Systems-6
> Forschungszentrum Julich,
> Germany


Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list