[gmx-users] GROMACS 4.5.1 mdrun re-compile for MPI

Mark Abraham Mark.Abraham at anu.edu.au
Thu Mar 24 14:00:37 CET 2011

On 24/03/2011 11:51 PM, Adam Herbst wrote:
> Dear GROMACS users,
> I successfully installed GROMACS 4.5.1 several months ago on a Mac Pro 
> with 12 CPUs, and the "mdrun" command (not "mpirun mdrun_mpi") allows 
> parallel simulations--it automatically uses multiple processors, while 
> the number of processors can be manually specified as N with the flag 
> "mdrun -nt N".  I understand that this is a feature of GROMACS 4 and 
> later.

Yes, threading, enabled by default, and mutually incompatible with MPI.

> Now I am making minor changes to the mdrun source code, and I want to 
> recompile such that the parallel version of mdrun is updated with my 
> changes.  But when I run:
>   make mdrun (or just make)
>   make install-mdrun (or just make install)
> from the top-level source directory, the only executables that are 
> updated are the ones with the _mpi suffix, such as mdrun_mpi.  The 
> version of mdrun in src/kernel/ is updated, but this one has no -nt 
> flag and cannot seem to run on multiple processors.  And when I run

Subsequently you have configured with --enable-mpi, so threading is 
disabled. Now everything is probably a mess.

>   mpirun -np N mdrun_mpi [options],
> the same simulation is started separately on each processor, leading 
> to a crash.  If I use
>   mpirun -np 1 -cpus-per-proc N mdrun_mpi [options],
> I get an error message that this is not supported on my computer ("An 
> attempt to set processor affinity has failed").
> I can't configure the input .tpr file for parallel because grompp 
> doesn't have the -np flag in GROMACS 4.
> How can I update the parallel-capable "mdrun" executable with my changes?

Run "make distclean" and then re-configure.


More information about the gromacs.org_gmx-users mailing list