[gmx-users] Grompp error on index file

Mr Bernard Ramos bgrquantum at yahoo.com
Tue May 31 04:02:41 CEST 2011

Hi everyone!
I added a residue on the gromacs 4.5.3 I have. I followed the instructions as indicated in the "Adding A Residue to a Force Field" with this link http://www.gromacs.org/Documentation/How-tos/Adding_a_Residue_to_a_Force_Field?highlight=adding+residue. I added the residue to residuetypes.dat and indicated it as a carbohydrate. The topology in fact was able to write it down as a carbohydrate. 
Generating a topology went well with pdb2gmx, editconf, genbox, energy minimization. However, I encountered the following error when I was about to do an NVT equilibration.
Program grompp, VERSION 4.5.3
Source code file: readir.c, line: 1316
Fatal error:
Group protein not found in indexfile.
Maybe you have non-default groups in your mdp file, while not using the '-n' option of grompp.
In that case use the '-n'option.
In response, I created an index file using make_ndx. The index file was able to generate correctly the molecule indices and identified it correctly as indicated in the residuetypes.dat and carbohydrate.rtp 
And then I tried (again) the following command:
$ grompp -f nvt.mdp -c molecule.gro -n index.ndx -p topol.top -o nvt.tpr. 
It still generates the same error as above. Please help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20110530/67a41b48/attachment.html>

More information about the gromacs.org_gmx-users mailing list