[gmx-users] UNK not found in residue topology

Justin A. Lemkul jalemkul at vt.edu
Mon Nov 14 22:52:11 CET 2011

Janowicz, Adrianna C. wrote:
> Hello,
> I'm getting an UNK not found in residue topology error message.
> After I run
> pdb2gmx -f XXX.pdb -o conf.pdb
> Fatal error:
> Residue 'UNK' not found in residue topology database
> I figured out what the error was and tried to add UNK as carbon to
> ffopslaa.rtf

There are no .rtf files used by Gromacs, so if you've created or edited one, it 
will have no effect.

> [UNK]
>  [ atoms ]
>     UNK     UNK      0.000     0
> but I am still getting the same error. What do I do?

In theory, one can define a residue named UNK with atom names and types of UNK, 
but that's an incredibly awkward mechanism.  It would probably be worthwhile to 
use real, existing atom types (which would be required by OPLS) with a 
meaningful residue name.  Perhaps the format of your .pdb file is wrong and 
pdb2gmx is reading another column for the residue name instead of the one 
intended.  If you specify everything as UNK, you'll never know.



Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list