[gmx-users] Installation gromacs in Scientific Linux

Nathalia Garces natsgarces at gmail.com
Wed Sep 7 05:01:50 CEST 2011


The last 6 months I've been working with gromacs (4.5.3 and 4.5.4) in Ubuntu
(10.4) and it has worked fine. The problem started when I changed the linux
distribution to Scientific Linux (5.3)... I followed the same steps to
download/configure gromacs but something's wrong or missing because the
simulations that I had been running on UBUNTU crashed in SL.

The command I use is very simple:

* mdrun -v -s topol.tpr*

In Ubuntu the simulation ends fine but in SL the application starts to write
on prompt at early steps (around 100)

*Step XX, time 0.XX (ps)  LINCS WARNING*
*relative constraint deviation after LINCS:*
*rms XX, max XX (between atoms XX and XX)*
*bonds that rotated more than 30 degrees:*
*Wrote pdb files with previous and current coordinates*
Until the simulation ends (around 250) with a message of

Segmentation fault

I tried different ways to configure gromacs but none of them seems to
resolve the problem
1) ./configure --prefix=<my path>
make install

2) ./configure --with-fft=fftw3 --prefix=<my path>  --without-x
make install

3)./configure --program-suffix= --disable-float --prefix=<my
path> --exec-prefix=<my path> --enable-all-static --with-fft=fftw3
make install

Moreover, I downloaded the benchmark posted in the gromacs web page to test
the simulations with other ".tpr" files. I run the first simulation
(implicit solvent) in UBUNTU and worked OK but the one on SL crashed (around
step 460) with the first two options of configuration. The last
configuration enabled the simulation to run OK( I decided to stop it at 4000
This bewilders me because the last configuration permitted the benchmark to
run OK but not my file. I don't think my file has an unstable system because
it works all right in UBUNTU (and also Debian!)

In addition, I upgraded my linux distribution to the latest SL 5.x release
but it didn't make any change!

I hope you can help me with some guide on how to proceed a GOOD instalation
in SL or to let me know what is my problem and what I am missing.

Thank you for four answer,

Nathalia Garces
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20110906/035797ef/attachment.html>

More information about the gromacs.org_gmx-users mailing list