[gmx-users] Parallel run on multiple nodes

Huaichen(Bobby) Zhang bobbyhczhang at gmail.com
Wed Apr 4 11:14:07 CEST 2012

Dear GROMACS users,

I'm a new user of GROMACS. The command "mpirun -np 8 mdrun" is working well
in a node with 8 processors.

Now I want to run GROMACS parallel on more processors, i.e., multiple
nodes. I tried to use "mpirun -n 16 -host node018,node022 mdrun" (node018
and node022 each has 8 processors), it gives the following message:
mpirun was unable to launch the specified application as it could not find
an executable:
Executable: mdrun
Node: node018
while attempting to start process rank 0.
I also tried to use "mpirun -hostfile hostlist mdrun" (hostlist file as
follows), the same message as above appeared.
node018 slots=8
node022 slots=8
While the same commands works well for other softwares. Have anyone
encountered similar problem? What is your solution?

Thanks in advance!

Huaichen(Bobby) ZHANG

+31 648478172
MSc Sustainable Energy Engineering
Royal Institute of Technology (Sweden)
Eindhoven University of Technology (Netherland)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20120404/9c1d341c/attachment.html>

More information about the gromacs.org_gmx-users mailing list