[gmx-users] Parallel run on multiple nodes

Mark Abraham Mark.Abraham at anu.edu.au
Wed Apr 11 17:13:54 CEST 2012

On 4/04/2012 7:14 PM, Huaichen(Bobby) Zhang wrote:
> Dear GROMACS users,
> I'm a new user of GROMACS. The command "mpirun -np 8 mdrun" is working 
> well in a node with 8 processors.

Maybe. Standard installation procedure is to suffix mdrun with _mpi so 
that you and everyone else can be really sure it's not a non-MPI 
executable (which could be successfully run with mpirun, but which does 
not run in parallel)

> Now I want to run GROMACS parallel on more processors, i.e., multiple 
> nodes. I tried to use "mpirun -n 16 -host node018,node022 mdrun" 
> (node018 and node022 each has 8 processors), it gives the following 
> message:
> "
> mpirun was unable to launch the specified application as it could not 
> find an executable:
> Executable: mdrun
> Node: node018
> while attempting to start process rank 0.
> "
> I also tried to use "mpirun -hostfile hostlist mdrun" (hostlist file 
> as follows), the same message as above appeared.
> "
> node018 slots=8
> node022 slots=8
> "
> While the same commands works well for other softwares. Have anyone 
> encountered similar problem? What is your solution?

(Some of) your execution hosts don't have an mdrun executable in their 
PATH, or at least don't when you use more than one node. Fixing that is 
a matter of system configuration, rather than GROMACS configuration. If 
other parallel software runs, then it seems their executables are in the 


More information about the gromacs.org_gmx-users mailing list