[gmx-users] gromacs 4.5.5 on Cygwin

vijaya subramanian vijaya65 at hotmail.com
Tue Apr 24 19:54:44 CEST 2012

Thanks for your earlier reply:
./configure worked after I set CPPFLAGS and LDFLAGS but I am still not able to install gromacs.

I configured using the following command:
 ./configure --disable-threads --enable-all-static --without-xml

It worked without any error messages.

I entered make and got the following error at the very end:

/usr/lib/gcc/i686-pc-cygwin/4.3.4/cc1.exe: error while loading shared libraries:
 ?: cannot open shared object file: No such file or directory
make[5]: *** [nb_kernel400_ia32_sse.lo] Error 1
make[5]: Leaving directory `/home/Administrator/gromacs-4.5.5/src/gmxlib/nonbond
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/Administrator/gromacs-4.5.5/src/gmxlib/nonbond
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/Administrator/gromacs-4.5.5/src/gmxlib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/Administrator/gromacs-4.5.5/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/Administrator/gromacs-4.5.5/src'
make: *** [all-recursive] Error 1

How can I fix this?

Date: Sun, 22 Apr 2012 13:28:42 +1000
From: Mark.Abraham at anu.edu.au
To: gmx-users at gromacs.org
Subject: Re: [gmx-users] gromacs 4.5.5 on Cygwin

    On 22/04/2012 9:30 AM, vijaya subramanian wrote:

        I am trying to install gromacs 4.5.5 on cygwin following the
        instructions in the wiki.

        I first installed fftw3 using the following commands:

        ./configure --enable-float


        make install


        I then tried installing gromacs using:

        ./configure --disable-threads 


        as well as

        ./configure --disable-threads --enable-all-static


        but I get the following error message and configure exits:


        checking for fftw3.h... yes

        checking for main in -lfftw3f... no

        configure: error: Cannot find fftw3f library


        I checked /usr/local/lib, it has:

        libfftw3f.a  libfftw3f.la  pkgconfig


        Can anyone help with this issue.


    configure doesn't look in /usr/local/lib by default. See




gmx-users mailing list    gmx-users at gromacs.org
Please search the archive at http://www.gromacs.org/Support/Mailing_Lists/Search before posting!
Please don't post (un)subscribe requests to the list. Use the 
www interface or send it to gmx-users-request at gromacs.org.
Can't post? Read http://www.gromacs.org/Support/Mailing_Lists 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20120424/6728f7f1/attachment.html>

More information about the gromacs.org_gmx-users mailing list