[gmx-users] Question about starting Gromacs 4.5.4 parallel runs using mpirun

Mark Abraham Mark.Abraham at anu.edu.au
Mon Apr 30 07:42:47 CEST 2012

On 30/04/2012 3:38 PM, Anirban Ghosh wrote:
> On Sat, Apr 28, 2012 at 10:22 PM, Andrew DeYoung 
> <adeyoung at andrew.cmu.edu <mailto:adeyoung at andrew.cmu.edu>> wrote:
>     Hi,
>     Typically, I use Gromacs 4.5.5 compiled with automatic threading.
>     As you
>     know, automatic threading is awesome because it allows me to start
>     parallel
>     runs without calling mpirun. So on version 4.5.5, I can start a
>     job on eight
>     CPUs using simply the command:
>     mdrun -s topol.tpr -nt 8
>     However, now I am using a different node on my department's
>     cluster, and
>     this node instead has Gromacs 4.5.4 (compiled without automatic
>     threading).
>     So, I must use mpirun to start parallel runs. I have tried this
>     command:
>     mpirun -machinefile mymachines -np 8 mdrun -s topol.tpr
> I suppose this mdrun executable is not mpi-enabled. Have you compiled 
> mdrun with "--enable-mpi" option?
> -Anirban
>     where mymachines is an (extensionless) file containing only the
>     text "c60
>     slots=8". (c60 is the name of the node that I am using.)
>     I get this error message:
>     "Missing: program name. Program mdrun either does not exist, is not
>     executable, or is an erroneous argument to mpirun."
>     This is strange, because mdrun is, I think, in my path. For
>     example, if I
>     type "mdrun -h", I get the manual page for mdrun (version 4.5.4).
>     Then I tried the command "which mdrun", and it gave me this output:
>     /usr/local/gromacs/bin/mdrun
>     So, next I tried to call mdrun via mpirun using the specific path
>     for mdrun:
>     mpirun -machinefile mymachines -np 8 /usr/local/gromacs/bin/mdrun -s
>     topol.tpr
>     This starts running my simulation, but when I look in "top", the
>     simulation
>     is only running on a single CPU; there is only one entry for mdrun
>     in "top",
>     and it has only %CPU=100 (not eight different entries for mdrun,
>     nor one
>     entry with %CPU=800). Also, the simulation is going at the speed I
>     would
>     expect for running on a single CPU -- it is very slow, so I am
>     convinced
>     that, as "top" suggests, mdrun is running on only one CPU.
>     Strangely, my colleagues are able to run jobs in parallel using
>     the exact
>     commands that I described above. So apparently something is wrong
>     with my
>     user ID, although there are no error messages (except the error
>     message
>     about "Missing: program name" that I described).
>     If you have time, do you have any suggestions for other things
>     that I can
>     try? Do you think that something could be wrong with my bashrc file?

Get a simple MPI test program and prove how you can run it in parallel. 
Then worry about GROMACS.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20120430/1de95571/attachment.html>

More information about the gromacs.org_gmx-users mailing list