[gmx-users] "X particles communicated to PME node Y are more than a cell length out of the domain decomposition cell of their charge group" error during minimization with TPO residue

Justin A. Lemkul jalemkul at vt.edu
Wed Jun 6 01:46:45 CEST 2012

On 6/5/12 7:36 PM, Alex Cumberworth wrote:
> I am trying to simulate a system with a phosphorylated threonine residue using
> Gromacs 4.5.5. I took the parameters for the TPO residue from the gromos43a1p
> force field and added them to the gromos43a1 force field, following the steps as
> provided on the Gromacs website. I then successfully completed the following steps.
> $bin/pdb2gmx -ignh -ff gromos43a1 -f odh.pdb -o odh.pdb -p odh.top -water spce
> $bin/editconf -bt octahedron -f odh.pdb -o odh-b4sol.pdb -d 1.0
> $bin/genbox -cp odh-b4sol.pdb -cs spc216.gro -o odh-b4ion.pdb -p odh.top
> $bin/grompp -f em.mdp -c odh-b4ion.pdb -p odh.top -o ion.tpr -maxwarn 5
> $bin/genion -s ion.tpr -o odh-b4em.pdb -neutral -conc 0.15 -p odh.top -g ion.log
> $bin/grompp -f em.mdp -c odh-b4em.pdb -p odh.top -o em.tpr -maxwarn 5
> I then tried to carry out the energy minimization (the em.mdp file is attached)
> $bin/mdrun -v -deffnm em
> Only to encounter the following error
> Fatal error:
> 6 particles communicated to PME node 4 are more than 2/3 times the cut-off out
> of the domain decomposition cell of their charge group in dimension x.
> This usually means that your system is not well equilibrated.

The message in the log file attached and printed here are not from EM, they are 
from MD.  What was the outcome of EM?  What were the values of Fmax and Epot? 
The log file appears to be running MD in the absence of any temperature coupling 
and other necessary parameters for proper equilibration, unless you are trying 
NVE, but the settings are also not correct for NVE, either.

Better minimization and/or proper settings for equilibration should alleviate 
the issue.


> Repeating the command causes different numbers of particles to be included in
> the error. I have attached a log file from mdrun. I repeated all steps with the
> same protein except with a THR in place of the TPO and found no errors. The
> initial structure had been minimized in CHARMM, so I downloaded the original pdb
> and tested it, only to find the same error. I then tried simulating a single TPO
> with the same set of steps (the editconf command option -d 1.0 was changed to
> 5.0) and found the same error. I then tried using the gromos43a1p force field
> more directly. I used the gromos43a1 .hdb (and added an entry for TPO) and .atp
> files in place of the the ones found in the gromos43a1p directory because of
> previously discussed issues with the format. I also added the ions.itp,
> spce.itp, and ff_dum.itp to the directory. However, after inputting the same
> commands and using the single TPO residue, I received the same error.
> Alex Cumberworth


Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list