[gmx-users] g_helix not recognizing protein backbone

Mark Abraham Mark.Abraham at anu.edu.au
Thu Mar 8 23:04:00 CET 2012

On 9/03/2012 8:50 AM, MPID wrote:
> I am running g_helix on a run involving a 37 residue protein in the charmm
> force field. It has two long alpha helical segments. I have tried running
> g_helix with many different variations of commands and getting rid of PBC
> effects, but I always get the same error:
> Checking group System
> There are 37 residues
> There are 0 complete backbone residues (from 0 to 524)
> -------------------------------------------------------
> Program g_helix, VERSION 4.5.5
> Source code file: /home/shared/installers/gromacs-4.5.5/src/tools/hxprops.c,
> line: 388
> Fatal error:
> rnr==0
> --------------------------------------------------------
> Is rnr the number of peptide residues, or the number that are helical? In
> either case, nothing I do can seem to make it different from 0.

The code is

   fprintf(stderr,"There are %d complete backbone residues (from %d to 
   if (rnr==0)

So zero complete backbone residues were found for some reason, and the 
person who wrote g_helix was cryptic about it.

The code relies on finding atoms named "N", "H", "CA", "C", "O" in the 
same residue.


More information about the gromacs.org_gmx-users mailing list