[gmx-users] Gromacs 4.6 segmentation fault with mdrun

Makoto Yoneya makoto-yoneya at aist.go.jp
Tue Nov 27 23:43:10 CET 2012

Dear GROMACS users:

On "Gromacs 4.6 segmentation fault with mdrun",
I'd also met the same segmentation fault problem with gromacs-4.6.
on my linux box with GTX-580.
For my case, change the compilor solved this problem.

Raf Ponsaerts wrote he used

> gcc 4.4.5 (Debian 4.4.5-8), Linux kernel 3.1.1
> CMake 2.8.7 .

These were same in the version when I first met the problem.
After that, I'd tried Intel compilor instead of gcc-4.4.x,
then the GPU jobs runs without the segmentation fault.
I also tried gcc-4.6.x and it also runs without
any faults (I'm using CentOS and its gcc version is currentry
gcc-4.4.x. Then, I had to compile gcc-4.6.x from the source.
gcc-4.7.x can't use with CUDA-4.2 since it only suppoorts
up to gcc-4.6.x.).

I suggest to try either intel compilor or gcc-4.6.x instead of

Makoto Yoneya, Dr.
AIST, Japan

More information about the gromacs.org_gmx-users mailing list