[gmx-users] Error with "grompp"

Justin Lemkul jalemkul at vt.edu
Mon Oct 1 14:38:15 CEST 2012

On 10/1/12 12:38 AM, Elie M wrote:
> Dear all,
> Maybe this error has been discussed before; I have checked previous messages on it but i could not resolve it. I have done a modified version of the oplsaa forcefield which I have called "ffoplsaamod.n2t". The top file was created successfully. However when I run grompp, I get the error:
> "Fatal error:Syntax error - File ffoplsaabon.itp, line 306Last line read:'[ bondtypes ]'"
> I tried to "uncomment" the bond types then the error moves to contraint types. What is the solution in this case?
> N.B: I have copied the file ffoplsaa.itp and called it "ffoplsaamod.itp".. Not sure if this has anything to do with the error.

It probably does.  The first #include statement in your topology is probably:

#include "ffoplsaa.itp"

That file, in turn, calls ffoplsaanb.itp and ffoplsaabon.itp.  If you have 
renamed the files, then ffoplsaanb.itp does not occur and cannot be #included 
prior to ffoplsaabon.itp.  The order of inclusion is essential for proper 

If you need to make adjustments to the contents of any of these files, make a 
local copy of the entire force field and make modifications, leaving the files 
located in $GMXLIB alone.  Do not rename them unless you consistently rename all 
references to these files.



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list