[gmx-users] error: group protein not found in index file

Liu, Hanzhong hliu at clarku.edu
Sun Oct 14 04:32:56 CEST 2012

Hi All:
    I'm trying to set up a small box with only water and ions (no protein) and run MD simulation. The commands I used to set up my system and running MD are as follows:
    genbox -cs spc216.gro -o water.gro -maxsol 256 -box 2.1 2.1 2.1
    pdb2gmx -f water.gro -q water.pdb -n index.ndx
    grompp -f ions.mdp -c water.gro -p topol.top -o ions.tpr
    genion -s ions.tpr -o water_ions.gro -pname NA -nname CL -nn 23 -np 23 -rmin 0.44 -p topol.top
    grompp -f mini.mdp -c water_ions.gro -p topol.top -o em.tpr 
    mdrun -v -deffnm em
    grompp -f nvt.mdp -c em.gro -p topol.top -o nvt.tpr 

And then I received the error message 

Fatal error:
Group Protein not found in index file.
Group names must match either [moleculetype] names
or custom index group names,in which case you
must supply an index file to the '-n' option of grompp.

Then I tried using make_ndx -f water_ions.mdp -o index.ndx to generate index file and tried grompp -f nvt.mdp -c em.gro -p topol.top -o nvt.tpr - index.ndx but still didn't work. In my system, there is no protein, so how can I setup the system correctly and run MD. Thanks!

what's in top file:

[ system ]
; Name
Generated by genbox

[ molecules ]
; Compound        #mols
SOL         210
NA               23
CL               23

More information about the gromacs.org_gmx-users mailing list