[gmx-users] Issue with domain decomposition between v4.5.5 and 4.6.1

Stephanie Teich-McGoldrick stephanietm at gmail.com
Mon Apr 15 05:23:37 CEST 2013

Dear all,

I am running a NPT simulation of 33,534 tip4P waters, and I am using domain
decomposition as the parallelization scheme. Previously, I had been using
Gromacs version 4.5.5 but have recently installed and switched to Gromacs
version 4.6.1. Using Gromacs 4.5.5 I can successfully run my water box
using domain decomposition over many different processor numbers. However
the same simulation returns the following error when I try Gromacs 4.6.1

"The initial number of communication pulses is: X 1 Y 1 Z 1
The initial domain decomposition cell size is: X 2.48 nm Y 2.48 nm Z 1.46 nm

When dynamic load balancing gets turned on, these settings will change to:
The maximum number of communication pulses is: X 1 Y 1 Z 1
The minimum size for domain decomposition cells is 1.000 nm
The requested allowed shrink of DD cells (option -dds) is: 0.80
The allowed shrink of domain decomposition cells is: X 0.40 Y 0.40 Z 0.68
The above error occurred running over 16 nodes / 128 processors. The system
runs for version 4.6.1 for 1,8, and 16 processors but not for 32,64, or 128

I have tried other systems (including NVT, Berendsen/PR barostats,
anisotropic/isotropic ) at the higher number of processors using both
version 4.5.5 and 4.6.1 and get the same result - v4.5.5 runs fine while
v4.6.1 returns the error type listed above.

Is anyone else having a similar issue? Is there something I am not
considering? Any help would be greatly appreciated! The details I have used
to compile each code are below. My log files indicate that I am indeed
calling the correct executable at run time.

Thanks in advance!
Computer architecture:
SUN X6275 blades
CPU: 2.93 GHz dual socket/quad core, Nehalem X5570 processors

Version 4.5.5
Compiler: openmpi-1.4.3_oobpr_intel-11.1-f064-c064 / intel-11.1-f064-c064
./configure COMPILER="intel-11.1-f064-c064" CC="mpicc" CXX="mpicpc"
CLINKER="mpicc" FC="mpif90" F77="mpif77" --without-x --disable-threads
--enable-mpi --enable-shared --prefix=mypath --oldincludedir=mypath

Version 4.6.1
Complier: openmpi-1.4.3_oobpr_intel-12.1-2011.7.256 / intel-12.1-2011.7.256
CC=mpicc CXX=mpicxx FC=mpif90 F77=mpif77 cmake -DGMX_CPU_ACCELERATION=SSE2

More information about the gromacs.org_gmx-users mailing list