[gmx-users] Installing Gromacs 4.6.3 using Cygwin

chem grad kelly.summers at usask.ca
Wed Dec 11 17:49:18 CET 2013


I am new to both Cygwin and Gromacs, so I apologize in advance if this error
is do to my computing ignorance. I downloaded the gromacs-4.6.3.tar.gz file
and tried to follow the 'Quick and Dirty Installation Instructions' to
install Gromacs 4.6.3 on my new Windows 8 machine, but encountered a couple

I started with $ tar xfz gromacs-4.6.3.tar.gz, then $ cd gromacs-4.6.3/, $
mkdir build, $ cd build, and then $ cmake .. -DGMX_BUILD_OWN_FFTW=ON and
everything went smoothly:
-- Configuring done
-- Generating done
-- Build files have been written to:

Then when I entered $ make I received the following from Cygwin:
Scanning dependencies of target gmxfftw
[  0%] Creating directories for 'gmxfftw'
[  0%] Performing download step (download, verify and extract) for 'gmxfftw'
-- downloading...
-- [download 0% complete]
-- [download 2% complete]
-- [download 26% complete]
-- [download 57% complete]
-- [download 84% complete]
-- [download 100% complete]
-- downloading... done
-- verifying file...
-- verifying file... done
-- extracting...
-- extracting... [tar xfz]
-- extracting... [analysis]
-- extracting... [rename]
-- extracting... [clean up]
-- extracting... done

... and so on until it stopped with the following error message:

[ 17%] Building C object
[ 17%] Building C object src/gmxlib/CMakeFiles/gmx.dir/thread_mpi/atomic.c.o
In file included from
error: field ‘timer_init’ has incomplete type
     struct timeval timer_init;
src/gmxlib/CMakeFiles/gmx.dir/build.make:3070: recipe for target
'src/gmxlib/CMakeFiles/gmx.dir/thread_mpi/atomic.c.o' failed
make[2]: *** [src/gmxlib/CMakeFiles/gmx.dir/thread_mpi/atomic.c.o] Error 1
CMakeFiles/Makefile2:1238: recipe for target
'src/gmxlib/CMakeFiles/gmx.dir/all' failed
make[1]: *** [src/gmxlib/CMakeFiles/gmx.dir/all] Error 2
Makefile:146: recipe for target 'all' failed
make: *** [all] Error 2

I found a fix for this error on the forum and entered  #define
HAVE_SYS_TIME_H into the impl.h file, then tried make again and it got
farther this time before I received the following error message:

[ 39%] Building C object
[ 39%] Building C object
make[2]: *** No rule to make target
needed by 'src/gmxlib/cyggmx-8.dll'.  Stop.
CMakeFiles/Makefile2:1238: recipe for target
'src/gmxlib/CMakeFiles/gmx.dir/all' failed
make[1]: *** [src/gmxlib/CMakeFiles/gmx.dir/all] Error 2
Makefile:146: recipe for target 'all' failed
make: *** [all] Error 2

Any help you can provide is much appreciated!

Thank you,

View this message in context: http://gromacs.5086.x6.nabble.com/Installing-Gromacs-4-6-3-using-Cygwin-tp5013268.html
Sent from the GROMACS Users Forum mailing list archive at Nabble.com.

More information about the gromacs.org_gmx-users mailing list