[gmx-users] Fatal error: Number of atoms in Topology is not the same as in Trajectory

Justin Lemkul jalemkul at vt.edu
Sat Jan 5 19:19:42 CET 2013

On 1/5/13 3:46 AM, Shima Arasteh wrote:
> Dear all,
> I have a system of POPC/Protein/water/ions to simulate. I am trying to simulate this system by getting ideas from Justin's tutorial of kalp15-dppc.
> I've passed all steps of EM, NVT, and NPT as I expected. But when I want to run mdrun, I get some errors about waters can not be settle. So, I tried to remove them from npt.gro, update the number of atoms in .gro file, and then update number of SOL molecules in top file.Finally I made a new index file to go on.
> Next, to start mdrun, I run this command:
> grompp -f md.mdp -c npt.gro -t npt.cpt -p topol.top -n index-new.ndx -o md_0_1.tpr
> and get this fatal error:
> Number of atoms in Topology is not the same as in Trajectory.
> In fact, I thought of updating npt.cpt file, but it's a binary file and I guess it's impossible. Does anybody knows what should I do?  Would you please give me advice?

Re-run equilibration with your altered system.  You had a (maybe) equilibrated 
system that you have now perturbed, so it's no longer equilibrated.  If the 
previous equilibration had been adequate (assuming your topology is stable and 
your .mdp settings are correct), then you should not have had to make these 



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list