[gmx-users] Problem with Installing Gromacs 4.6.1 with GPU

salehi salehi at umich.edu
Sat May 11 02:07:36 CEST 2013

I was trying to install gromacs 4.6.1 with CUDA and have a weird problem. 
My system is as the following 
new iMAC OS x 10.8.3 
GPU : FTX 650 M 512 MB 
I also installed the open-mpi libraries into the /usr/local/lib folder
before installation. I have got to say I'm by no means a UNIX expert.
although I have installed gromacs 4.6.1 with float double and mpi options
but they were all without GPU options. SO when I started installing 4.6.1
version with GPU I ran into problems. So I figured it has got to have sth to
do with the GPU! I don't know what environment variables I needed have
changed before installation with CMAKE, So I would appreciate it if the
experts here help me out. 

Firstly, I have installed FFTW3.3.3 with these options: 

./configure --prefix /usr/local/fftw3 --enable-sse2 --enable-float
make $$ make install 

so the fftw3 installation folder is /usr/local/fftw3. 
my cuda source directory is located at :  /usr/local/cuda 
and for the cmake options to install the gromacs.Then, 
in the build folder within the gromacs root folder 
cmake -DGMX_FFT_LIBRARY=fftw3
-DFFTW_INCLUDE_DIR='/usr/local/fftw3/include/' -DGMX_GPU=ON
-DCMAKE_INSTALL_PREFIX=/usr/local/gromacs-4.6.1 ../ 

First of all I get the error which says the libfftw3f can not be found. 
The following is my fftw3 installation folder : 
drwxr-xr-x  3 root      102 26 Apr 22:04 pkgconfig 
-rwxr-xr-x  1 root      899 26 Apr 22:04 libfftw3f.la 
-rw-r--r--  1 root  2421656 26 Apr 22:04 libfftw3f.a 

As you can see the file libfftw3f.a is in the folder I have netered in the
cmake options. I don't know if there is any CMAKE variables I needed have
changed here, So I worked around that  by copying the contents of the
fftw3/lib folder to the usr/local/lib and since cmake looked into that
folder it found the fftw file and thus ignored my manual addresses for fftw
library. This time, the cmake command with the same options as above ran
successfully. However when I run the make I get: 
sudo make 

[  0%] Building NVCC (Device) object
clang: error: unsupported option '-dumpspecs' 
clang: error: no input files 
CMake Error at gpu_utils_generated_memtestG80_core.cu.o.cmake:206 (message): 
  Error generating 

make[2]: ***
Error 1 
make[1]: *** [src/gmxlib/gpu_utils/CMakeFiles/gpu_utils.dir/all] Error 2 
make: *** [all] Error 2 

I don't know if there is anything wrong with the installation of CUDA but I
could confirm that all the files that needed be there were there after
following CUDA's own web site. 
Thank you so much in advance.

View this message in context: http://gromacs.5086.x6.nabble.com/Problem-with-Installing-Gromacs-4-6-1-with-GPU-tp5008119.html
Sent from the GROMACS Users Forum mailing list archive at Nabble.com.

More information about the gromacs.org_gmx-users mailing list