[gmx-users] Re: Segmentation Fault using g_cluster

deplazes e.deplazes at uq.edu.au
Fri Sep 6 07:19:09 CEST 2013

Hi guys 

do you have an idea what is causing the segmentation fault with g_cluster?

I do the following 

1 . I combine trr files from different simulations using trjcat and select
backbone atoms only

trjcat  -f ../../*C/runs/*/*trr -cat -n index.ndx -o trajout_combined.xtc 

2. I make a new .tpr file for the backbone atoms only 

tpbconv -s run_1.tpr -nsteps -1 -n index.ndx -o topol.tpr 

3. I run g_cluster on the combined trajout with the new tpr selecting
backbone for RMSD fit and output

g_cluster -f trajout_combined.xtc -n index.ndx -s topol.tpr -fit -method
gromos -sz clust-size_0.20.xvg -o rmsd-clust_0.20.xpm -g cluster_0.20.log
-clid clust-id_0.20.xvg  -cl clusters_0.20.pdb -dist rmsd-dist_0.20.xvg 
-cutoff 0.20 

the output is 

Allocated 12066120 bytes for frames
Read 1202 frames from trajectory trajout_combined.xtc
Computing 1202x1202 RMS deviation matrix
# RMSD calculations left: 0        

The RMSD ranges from 0.0601062 to 0.533457 nm
Average RMSD is 0.321503
Number of structures for matrix 1202
Energy of the matrix is 160.564 nm
WARNING: rmsd minimum 0 is below lowest rmsd value 0.0601062
Making list of neighbors within cutoff 100%
Finding clusters    7

Found 7 clusters

Writing middle structure for each cluster to clusters_0.20.pdb
Segmentation fault

I have tried using less frames (using -dt 500 for trjcat) as to check that
it is not a memory issue but still get the seg fault 

The g_cluster works if I use a trajectory from a single simulations but not
for hte combined trajout. 

I am getting a segmentation fault with both gromacs 4.5.5 (on my macbook
pro) and 4.6.3 on raijin.nci.org.au (our supercomputing facilities in


View this message in context: http://gromacs.5086.x6.nabble.com/Segmentation-Fault-using-g-cluster-tp4662864p5011006.html
Sent from the GROMACS Users Forum mailing list archive at Nabble.com.

More information about the gromacs.org_gmx-users mailing list