[gmx-users] MD simulation with tip5p (with amber99sb)

Irem Altan irem.altan at duke.edu
Wed Oct 28 18:40:23 CET 2015


I am trying to run an MD simulation with tip5p, using amber99sb. When I look at the folder amber99sb.ff, I see that there exists a tip5p.itp file. However, when I do

pdb2gmx -f 1ytt_refine_001.pdb -ff amber99sb  -o box.gro -p topol.top

I don’t see an option for the water model:

Select the Water Model:
 1: TIP3P     TIP 3-point, recommended
 2: TIP4P     TIP 4-point
 3: TIP4P-Ew  TIP 4-point optimized with Ewald, recommended
 4: SPC       simple point charge
 5: SPC/E     extended simple point charge
 6: None

So I tried the following:

pdb2gmx -f 1ytt_refine_001.pdb -ff amber99sb -water tip5p -o box.gro -p topol.top

which gives the following error:

Residue 'HO5' not found in residue topology database

So then I tried modifying the aminoacids.rtp file in amber99sb.ff, by adding the following:

; tip5p
[ HO5 ]
 [ atoms ]
    OW  OW             0.00     0
   HW1  HW             0.241    0
   HW2  HW             0.241    0
   MW   MW            -0.241    0
   MW   MW            -0.241    0
 [ bonds ]
   OW   HW1
   OW   HW1

Which, upon running pdb2gmx -f 1ytt_refine_001.pdb -ff amber99sb -water tip5p -o box.gro -p topol.top   resulted in the following error:

Fatal error:
There were 384 missing atoms in molecule Water, if you want to use this incomplete topology anyhow, use the option -missing

What am I missing? How can I run an MD simulation with tip5p?


More information about the gromacs.org_gmx-users mailing list