[gmx-users] Problems with non standar residue combining Amber and GAFF

Rebeca García Fandiño regafan at hotmail.com
Mon Nov 21 12:03:50 CET 2016

Dear Gromacs users,

I am trying to add a new residue into a peptide composed of standar residues. For that I have used Antechamber to get a starting topology for that residue, obtained the corresponding .itp file in GROMACS (using amb2gmx.pl) and then modified the corresponding files in Amber99sb.ff force field (aminoacids.rtp, aminoacids.arn, atomtypes.dat, etc) incorporating the information of this new residue.

In a first approximation I have tried to include directly the file gaff.dat into forcefield.itp (#include "gaff.dat"), but then I also separated the different sections of gaff.dat and tried to included into ffbonded.itp file separately. In both cases pdb2gmx works without errors. However, when I execute grompp, I get errors complaing about gaff parameters (for example "   Too few gb parameters for type br-br").

I have noticed that the type of data of gaff.dat file is not the same than the both files is not the same than that found in ffbonded.itp. For example, in ffbonded.itp from Amber:

[ bondtypes ]
; i    j  func       b0          kb
  C  C          1     0.1525   259408.0 ; new99
  C  OS         1     0.1323   376560.0 ; new99
  C  H4         1     0.1080   307105.6 ; new99

whereas the analogous section in gaff.dat is:

ow-hw  553.0    0.9572      TIP3P water
br-br  123.2    2.542        SOURCE1     4    0.0000    0.0000
br-c   240.3    1.946        SOURCE2     2    0.0285    0.0285
br-c1  352.7    1.787        SOURCE2     4    0.0022    0.0024

So, I suppose my errors come from the  non correct definition of bondtypes, etc of the gaff parameters from my new residue.

How could I properly translate the information contained in gaff.dat to the files ffbonded.itp in Amber?

Thanks a lot for your help.

Best wishes,


Dr. Rebeca Garcia
Santiago de Compostela University

More information about the gromacs.org_gmx-users mailing list