[gmx-users] Problem with Ryzen, threads and core dumps?

Steffen Graether graether at uoguelph.ca
Wed Aug 9 00:04:06 CEST 2017


I am trying to run a protein/water simulation using a new computer (Ryzen 1700X, Nvidia GTX 1070 running Ubuntu 17.04). I compiled GROMACS 2016.3 with gcc-5 (CUDA 8.0 complained that it only supports up to version 5) and -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON, otherwise defaults were used. The build passed all make check tests.

During the production mdrun, I would get core dumps almost all of the time (mostly segmentation faults, sometimes illegal instructions, once it actually completed the 1 ps run). I also tried different water (TIP4P2005 and SPCE), but no change. I haven’t tried a different forcefield yet (just Amber ff03WS), but feel like that isn’t the problem.

Suggestions I found online seem to be mostly about not having compiled gmx on the current machine, which I had done. I also tried recompiling with SSE4.1, but still got a core dump. Interestingly restricting the program to the number of physical cores (-nt 8) lets the run complete more often (3/4 attempts), but still crash.

I would be appreciative of any suggestions people may have for compiling a more stable executable.


More information about the gromacs.org_gmx-users mailing list