[gmx-users] Errors in building GMX 5.1.x on Redhat 6.5 (a lot of "Undefined reference to ..")

Qing Lv lvqingjiejie at 163.com
Fri Feb 3 05:55:05 CET 2017

Hi Colleagues,

I am trying to build GMX 5.1.x (tried 5.1.4, 5.1.1, & 5.1) on a Redhat 6.5 server; I have updated GCC compiler and all dependent libraries (tried GCC 4.9.4 and GCC 6.3.0). (The built-in compiler of Redhat 6.5 is GCC 4.4.7, which is too old.)
I used the commmand
export CC=gcc
export CXX=gcc
cmake .. -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON                      # No errors reported till now
When 100% completed, I got a lot of error messages like
../../lib/libgromacs.so.1.0.0: Undefined reference to ‘std::runtime_error::what() const’
../../lib/libgromacs.so.1.0.0: Undefined reference to ........
../../lib/libgromacs.so.1.0.0: Undefined reference to ........
And the error messages finished with
collect2: Error: ld returns 1
make[2]: *** [bin/template] Error 1
make[1]: *** [share/template/CMakeFiles/template.dir/all] Error 2
make: *** [all] Error 2

Any friends can help? Thanks
BTW, I have just successfully compiled GMX 5.1.4 on Cygwin.


More information about the gromacs.org_gmx-users mailing list