[gmx-users] Gromacs and Radeon Nano

melichercik at leaf.nh.cas.cz melichercik at leaf.nh.cas.cz
Wed Feb 8 02:29:20 CET 2017

Hi people,
I have computer with 2x Xeon E5-2660 with Radeon Fury (as someone here recomended it as quite decent card (not the best one ;-) of course ). System is debian (testing). I have previously R9 280X instead and it worked without problem. After I replaced less power hungry Radeon Fury, it freezes the machine from time to time (but at least one a day) or in better case segfaults gromacs. I tryied latest fglrx (15.12) and all amdgpu-pro (16.40, 16.50 and 16.60) and gromacs (I think) all versions from 5.1 to 2016.2. With exception of latest Amdgpu-pro 16.60 which totaly failed in runing OpenCL-enabled GMX, it gets better in time, but it still crashes. So do have someone any idea wich could help?
Thanks in advance.



PS: PSU is EVGA Supernova B2 750 W, which should be quite enough (and more hungry R9 280X worked) and it should be quite good PSU (by Tier2 of Tom's Hardware list)
PS2: maybe it is not important, but I think I have tested/simulated only .tpr created in older versions of GMX than 2016.x (which I used mostly for simulating)
PS3: why is all Radeon GPU using amdgpu-pro detected twice? ()see below) (at least I have tested with Radeon Nano and RX460 cards). And the 2nd one doesn't work, I have to use -gpu_id parameter.

Hardware detected:
  CPU info:
    Vendor: Intel
    Brand:  Intel(R) Xeon(R) CPU E5-2660 0 @ 2.20GHz
    SIMD instructions most likely to fit this hardware: AVX_256
    SIMD instructions selected at GROMACS compile time: AVX_256

  Hardware topology: Full, with devices
  GPU info:
    Number of GPUs detected: 2
    #0: name: Fiji, vendor: Advanced Micro Devices, Inc., device version: OpenCL 1.2 AMD-APP (2236.5), stat: compatible
    #1: name: AMD FIJI (DRM 3.8.0 / 4.9.0-1-amd64, LLVM 3.9.1), vendor: AMD, device version: OpenCL 1.1 Mesa 13.0.3, stat: compatible

More information about the gromacs.org_gmx-users mailing list