[gmx-users] error in nvidia cuda installation

Mark Abraham mark.j.abraham at gmail.com
Mon Jul 3 19:13:33 CEST 2017

On Mon, Jul 3, 2017 at 5:59 PM Neda Rafiee <nerafiee at ipm.ir> wrote:

> Dear users,
> I am going to install GROMACS 5.1.4 which is enabled for parallelization,
> so I tried to install Cuda Nvidia as it is suggested in the gromacs
> website. I am using Linux Mint 18.1
> I tried to download Cuda toolkit from its website but the link seems not
> to work properly at the present time. Here it is:
> http://developer2.download.nvidia.com/compute/cuda/8.0/secure/Prod2/local_installers/cuda-repo-ubuntu1604-8-0-local-ga2_8.0.61-1_amd64.deb?vmYFoBWDG3rPn44_PXesEZzhZKZBfQhZUlE0ejZIsLsGUAyLFN5AVFpzvAECUUPTxrKQY78vMi1MEyMHXyYaoupnSvADVKrj_DDrxr4eeE2OJUgAFzbT4fVBHMQzAAuc_DiJsX1S6JwRlyeOsS4XbS-uHan2fLyrDDCr03z0AnFyffKbewEUrFyrCz57hrLGTe9pTeniMd87kBD4mXqZ9AXr1g

Go to https://developer.nvidia.com/cuda-downloads and get the one for
ubuntu 16.04. Or follow one of the blog posts for Mint+CUDA. My advice is
to choose your distro to suit what you need (ie perhaps CUDA) rather than
whatever is attractive about Mint.

I also tried downloading via " apt-get install nvidia-cuda-toolkit ", as
> suggested in the link below:
> https://askubuntu.com/questions/640577/install-cuda-7-0-on-ubuntu-14-04-2
> but after entering " sudo apt-get install nvidia-XXX nvidia-prime ", I got
> an error indicating "E: Unable to locate package nvidia-XXX "
> Anyone knows what should I do?

Read the rest of that post where it explains what XXX is


> Thanks.
> --
> Gromacs Users mailing list
> * Please search the archive at
> http://www.gromacs.org/Support/Mailing_Lists/GMX-Users_List before
> posting!
> * Can't post? Read http://www.gromacs.org/Support/Mailing_Lists
> * For (un)subscribe requests visit
> https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-users or
> send a mail to gmx-users-request at gromacs.org.

More information about the gromacs.org_gmx-users mailing list