[gmx-users] Gromacs 2018 installation failed

Qinghua Liao scorpio.liao at gmail.com
Fri Feb 9 15:31:10 CET 2018

Dear GMX developers,

I am trying to install Gromacs2018 with cuda on clusters, the 
installation was successful on one cluster,
but failed on the other cluster. I guess there might be some library 
missing on the other cluster.

For the succeeded one, the operating system is openSUSE 42.2 (GNU/Linux 
4.4.27-2-default), the compilers are gcc and c++ 4.8.5,
the CUDA version is 9.0.176, the MPI is openMPI 1.10.3

For the failed one, the operating system is Ubuntu 16.04.3 (GNU/Linux 
4.4.0-109-generic x86_64), I tried CUDA 9.1.85  and 9.0.176,
together with gcc/c++ version 6.4, icc/icpc 2017.4, all were failed. The 
error is the same:

-- Performing Test CXX11_STDLIB_PRESENT
-- Performing Test CXX11_STDLIB_PRESENT - Failed
CMake Error at cmake/gmxTestCXX11.cmake:210 (message):
   This version of GROMACS requires C++11-compatible standard library.  
   use a newer compiler, and/or a newer standard library, or use the GROMACS
   5.1.x release.  Consult the installation guide for details before 
Call Stack (most recent call first):
   CMakeLists.txt:168 (gmx_test_cxx11)

Here is my command:

I am confused here that the old compilers worked but the new ones did 
not, while the error message suggests to use newer compilers.
Could some one help me with fixing it? Thanks a lot!

All the best,

More information about the gromacs.org_gmx-users mailing list