[gmx-users] Bad contact error for gromacs 5.0.4 but running in 4.6.5

Santanu Santra santop420 at gmail.com
Tue Sep 4 15:43:58 CEST 2018

hi all,
       I have two sets of solutions containing solute 0.5 M and 2M in
water. While I was simulating 2 M solution this was running successfully
without error in gromacs 4.6.5 version but getting error in gromacs 5.0.4
version with the same input gro file and same mdp file.

The error in gromacs 5.0.4 is :::::::::::::::::::::::::::::::::

Polak-Ribiere Conjugate Gradients:
   Tolerance (Fmax)   =  1.00000e+03
   Number of steps    =      5000000
   F-max             =  9.56087e+02 on atom 432
   F-Norm            =  1.37462e+02

step -1: Water molecule starting at atom 1236 can not be settled.
Check for bad contacts and/or reduce the timestep if appropriate.

WARNING: Listed nonbonded interaction between particles 1121 and 1135
at distance 2.693 which is larger than the table limit 2.000 nm.

This is likely either a 1,4 interaction, or a listed interaction inside
a smaller molecule you are decoupling during a free energy calculation.
Since interactions at distances beyond the table cannot be computed,
they are skipped until they are inside the table limit again. You will
only see this message once, even if it occurs for several interactions.

IMPORTANT: This should not happen in a stable simulation, so there is
probably something wrong with your system. Only change the table-extension
distance in the mdp file if you are really sure that is the reason.

Step 0, Epot=        -nan, Fnorm=     -nan, Fmax=3.990e+08 (atom 1130)
[XXX:09843] *** Process received signal ***
[XXX:09843] Signal: Segmentation fault (11)
[XXX:09843] Signal code: Address not mapped (1)
[XXX:09843] Failing at address: 0xfffffffe030f98c0
[XXX:09843] [ 0] /lib64/libpthread.so.0[0x357040f710]
[XXX:09843] [ 1]
[XXX:09843] [ 2]
[XXX:09843] [ 3]
[XXX:09843] [ 4]
[XXX:09843] [ 5]
[XXX:09843] [ 6]
[XXX:09843] [ 7]
[XXX:09843] [ 8] mdrun_mpi(mdrunner+0x1056)[0x420e26]
[XXX:09843] [ 9] mdrun_mpi(_Z9gmx_mdruniPPc+0x1811)[0x42e7b1]
[XXX:09843] [10]
[XXX:09843] [11] mdrun_mpi(main+0x87)[0x40bd07]
[XXX:09843] [12] /lib64/libc.so.6(__libc_start_main+0xfd)[0x356fc1ed1d]
[XXX:09843] [13] mdrun_mpi[0x40bbb9]
[XXX:09843] *** End of error message ***
Segmentation fault (core dumped)
also I tried to give minimized gro file(minimized in gromacs 4.6.5) as
input gro file for again minimization in gromacs 5.0.4  but still getting
the same error.
also I tried to rescale the system by taking em.gro (minimized in gromacs
4.6.5) in gromacs 5.0.4 but still getting the same error.
(1) Although the system is very dense but if it is running in gromacs 4.6.5
version then why not for gromacs 5.0.4 ?
(2) In order to run in gromacs 5.0.4 version what modification in mdp file

Any suggestion is highly appreciated.

Thanks in advance.
Santanu Santra


More information about the gromacs.org_gmx-users mailing list