[gmx-users] atom types not found

paul buscemi pbuscemi at q.com
Tue Sep 25 03:42:24 CEST 2018

This is a version of a very old question

Using Avogadro, I’ve built an all atom version of nylon12, ( 45 atoms ) converted to a gro file with editconf.  I want to generate the rtp so I can construct a polymer.  Using x2top, I’ve tried using both  gromos 54a7 ff  and oplsaaff.  there are two outcomes:

1) if trying 54a7,  I am warned that the atomnames2types.n2t  is not found ( and indeed it is not present in the ff subfolder ) .  I’ve done what I think is an extensive search ( eg github, etc ), but have not found a n2t for 54a7.  I tried to construct one following that found in oplsaa but that has not worked out -yet.  Does 54a7ff require an n2t file  and if so what is the format ?

2) In trying oplsaa,  I am warned  only 44 of 45 atom types are found.. It turns out that it is the Nitrogen that is the culprit.  If I convert the nitrogen to carbon in the gro , file the top and rtp are completed.  It’s hard to believe that an amide nitrogen is not in the force field.  Thinking it may be  my model, I downloaded arginine from “aminoacidsguide.com” to avoid Avogadro.  With Aginine only 19 of 26 atoms were found in the oplassff. What ?  I can’t make an rtp for arginine without modifying the ffbonded or n2t for oplsaa.    Is  x2top simply not the right tool ?

Note if I  submit the nylon pdb to ATB get back a usable itp,  and it is possible to generate a small polymer this way, ( 20 mers or so ).  But I should be able to construct a polymer similar to the example given  for PE  some 9 years ago using a beginning, middle mers.  But I need the rtp.

Thanks for any responses
Paul Buscemi, Ph.D.

More information about the gromacs.org_gmx-users mailing list