[gmx-developers] Problem submitting GROMACS script

Mark Abraham Mark.Abraham at anu.edu.au
Mon Aug 3 01:43:13 CEST 2009

rainy908 at yahoo.com wrote:
> Justin,
> You are correct about my attempt to run grompp using MPIRUN - it doesn't
> work.  Actually I realized that I was using a version of Gromacs that wasn't
> compiled for MPI!  Gromacs-3.3.1-dev is compiled for MPI, however.  The
> submission script that worked is as follows:
> # Define locations of MPIRUN, MDRUN
> MPIRUN=/usr/local/topspin/mpi/mpich/bin/mpirun
> MDRUN=/share/apps/gromacs-3.3.1-dev/bin/mdrun
> cd /nas2/lpeng/nexil/gromacs/cg_setup
> # Run MD
> $MDRUN -v -nice 0 -np $NSLOTS -s md3.tpr -o md3.trr -c confout.gro -g
> md3.log -x md3.xtc
> ..This was carried out  after I ran grompp on a single node.

That still won't run a parallel mdrun. Justin indicated the correct 

Also, unless you know a good reason for using a version of GROMACS 3(?) 
years old, use an up-to-date one. It'll be heaps faster.


More information about the gromacs.org_gmx-developers mailing list