[gmx-developers] mdp option names

Alexey Shvetsov alexxy at omrb.pnpi.spb.ru
Thu Oct 20 21:21:33 CEST 2011

Hi all!

Seems it will be good idea to have all mdp option names consistent. In 
current state some of them has '-' in its names like E-t while some 
options has '_' in their names like init_step. It will be good if all 
will have same naming scheme like only '_' in names or only '-' in its 
Also it will simplyfy mdp file generation and parsing  by external 

I prepared two patches in gerrit

https://gerrit.gromacs.org/229 <- it replaces '_' to '-' in mdp option 

https://gerrit.gromacs.org/229 <- it changes mdp.html and mdp_opt.html

PS currently we use such mdp file parser for gromacs grid ui in nnn 

Best Regards,
Alexey 'Alexxy' Shvetsov
Petersburg Nuclear Physics Institute, Russia
Department of Molecular and Radiation Biophysics
Gentoo Team Ru
Gentoo Linux Dev
mailto:alexxyum at gmail.com
mailto:alexxy at gentoo.org
mailto:alexxy at omrb.pnpi.spb.ru

More information about the gromacs.org_gmx-developers mailing list