[gmx-developers] mdp option names

Justin A. Lemkul jalemkul at vt.edu
Thu Oct 20 21:23:15 CEST 2011

Aren't the hyphen and underscore interchangeable, such that either is already 


Alexey Shvetsov wrote:
> Hi all!
> Seems it will be good idea to have all mdp option names consistent. In its
> current state some of them has '-' in its names like E-t while some other
> options has '_' in their names like init_step. It will be good if all 
> options
> will have same naming scheme like only '_' in names or only '-' in its 
> names.
> Also it will simplyfy mdp file generation and parsing  by external 
> software.
> I prepared two patches in gerrit
> https://gerrit.gromacs.org/229 <- it replaces '_' to '-' in mdp option 
> names
> https://gerrit.gromacs.org/229 <- it changes mdp.html and mdp_opt.html
> PS currently we use such mdp file parser for gromacs grid ui in nnn grid


Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-developers mailing list