[gmx-developers] Minor CMAKE/fftw3 problem VS2010 x64 on release-4-6 branch

Mirco Wahab mirco.wahab at chemie.tu-freiberg.de
Wed Feb 22 17:52:59 CET 2012

Am 22.02.2012 17:35, schrieb Christoph Junghans:
> Am 22. Februar 2012 09:10 schrieb Mirco Wahab
>> Am 22.02.2012 16:42, schrieb Christoph Junghans:
>>>> FFTW_INCLUDE_DIR:STRING=D:/Lib64/include
>>>> FFTW_LIBRARY:STRING=D:/Lib64/lib/libfftwf-3.3.lib
>>> Hmm, the "D" here make me nervous. I am not sure where does this comes
>>> from.
>>> And I guess that is the reason why it does not work automatically.
>> OK, I started over "without" the drive designator:
>>         FFTW_INCLUDE_DIR:STRING=/Lib64/include
>>         FFTW_LIBRARY:STRING=/Lib64/lib/libfftw-3.3.lib
>>         FFTW_INCLUDE_DIR_fftw3f:PATH=/Lib64/include
>>         FFTW_LIBRARY_fftw3f:FILEPATH=/Lib64/lib/libfftw-3.3.lib
> Sorry, I forgot on Windows, you have to put the drive designator:
> Have you used "\" instead of "/" as a path separator, like
> FFTW_LIBRARY="D:\Lib64\lib\libfftw-3.3.lib"

Yes, I tried this:


with installed pkg-config


*Same result*. No dependency to fftw3 generated.

> The problem here is, that if you set  FFTW_LIBRARY (or any other
> variable) by hand cmake believes you without checking it again.

Before using the 4.6-release branch (yesterday),
I compiled the 4.6-master(5.0) version without
problems regarding fftw3 linkage.

BTW: The gsl/gslcblas and xml linkage works!


Thanks & Regards


More information about the gromacs.org_gmx-developers mailing list