[gmx-developers] Configure error on Macbook Air with gcc - despite GMX_ACCELERATION

Jochen Hub jhub at gwdg.de
Sat Apr 13 17:21:43 CEST 2013

Hi all,

I don't manage to configure 4.6 (latest git version) on my Macbook Air.
With gcc 4.7 from Macports I always get

   Cannot compile AVX intrinsics.  Consider switching compiler.

I tried different -DGMX_ACCELERATION settings (SSE4.1, SSE2, none), but 
this seems to be ignored. The relevant cmake output lines are:


-- Detecting best acceleration for this CPU - AVX_256
-- Performing Test GNU_AVX_CFLAG - Success
   Cannot compile AVX intrinsics.  Consider switching compiler.

I also tried with the i686-apple-darwin11-llvm-gcc-4.2, but that gives

   No C AVX flag found.  Consider a newer compiler, or try SSE4.1 (lower
   Cannot find immintrin.h, which is required for AVX intrinsics support.
   Consider switching compiler.

So the issue seems that the -DGMX_ACCELERATION=SSE2 flat is ignored, and 
cmake always tries to use AVX.

Any suggestions how to get 4.6 compiled at present?

Many thanks,

For the sake of completeness, this is the cmake line:

CC=`which gcc-mp-4.7`; CXX=`which g++-mp-4.7`

rm -rf CMake* *.cmake cmake*
cmake ../gromacs \
     -DGMX_X11=OFF \
     -DGMX_MPI=OFF \
     -DGMX_GPU=OFF \
     -DGMX_ACCELERATION=SSE2 # or other setting or no line - makes no 

Dr. Jochen Hub
Computational Molecular Biophysics Group
Institute for Microbiology and Genetics
Georg-August-University of Göttingen
Justus-von-Liebig-Weg 11, 37077 Göttingen, Germany.
Phone: +49-551-39-14189

More information about the gromacs.org_gmx-developers mailing list