[gmx-users] altivec beta version on MacOSX: first impressions

nicolis at guideo.fr nicolis at guideo.fr
Wed Nov 28 19:00:59 CET 2001

First of all: it works and it's fast :-)

Into the details now:

I downloaded and compiled the beta on a G4/867MHz and a G3/233MHz
It compiles on both with the -faltivec option automatically selected by the
configure script and, when run on the G4, it displays that it uses altivec.
I tried the same mdrun simulation on both and the G4/867MHz apperas to be about
6 times faster than the G3/233MHz.

You were right about zsh vs bash: Under zsh, configure fails to correctly
prepare the sed lines in the Makefile. I downloaded and installed bash and "bash
./configure" works with no problem.

Also, there is no need anymore to link to the malloc.h as I had to do with the
original version.

Some problems:

When trying to read on the G3 with ngmx a .trr file coming from the G4, it fails
with a "trying to read a 21 version file with version 20". But It is the same
sources I compiled on both machines.

Second problem: on the G3 (not yet tried on the G4) g_sas complains a lot about
"freeing not malloced address" but eventually completes producing results.

Final two problems that I have also on the PC linux machines:

first, grace (xmgr) don't understands the labels and some (-xdy or something
like this?) options from g_sas.

second, the motif windows( the -X option) display correctly but when clicking on
browse they don't display any file on the selector.

That's all, thanks for the great job.
If you are interested on benchmarking tell me and I will download gmxbench to
try it.


More information about the gromacs.org_gmx-users mailing list