[gmx-users] mpirun on lam again

Y. U. Sasidhar sasidhar at chem.iitb.ac.in
Wed Apr 17 06:43:04 CEST 2002

Erik Lindahl wrote:

> system loads these routines from libmd_mpi.so or libgmx_mpi.so (i.e. the
> common routines are not duplicated).
> For this to work, the system must know where to find the *.so files. By
> default, it looks in the place where it was installed, i.e.
> /usr/local/lib, but you can also tell the system to look for them in any
> other directory by adding that directory to the environment variable

looks like I have these in /usr/local/lib :

sasidhar at cluster:/usr/local/lib$ ls *mpi.so
libfftw_mpi.so  libmd_mpi.so     libsfftw_mpi.so
libgmx_mpi.so   librfftw_mpi.so  libsrfftw_mpi.so
sasidhar at cluster:/usr/local/lib$ ls *mpi.so.2
libfftw_mpi.so.2  libmd_mpi.so.2     libsfftw_mpi.so.2
libgmx_mpi.so.2   librfftw_mpi.so.2  libsrfftw_mpi.so.2

I tried also:
export LD_LIBRARY_PATH = /usr/local/lib
I still get the same error:
mdrun_mpi: error while loading shared libraries: libmd_mpi.so.2: cannot open
red object file: No such file or directory

I also used -x LD_LIBRARY_PATH option with mpirun. Still same error.

Lam version: LAM 6.5.6/MPI 2 C++/ROMIO - University of Notre Dame

May be lam version is a problem ?


More information about the gromacs.org_gmx-users mailing list