[gmx-users] trying to install

Erik Lindahl erik at theophys.kth.se
Sat Jan 5 13:22:21 CET 2002

nesanfor at criba.edu.ar wrote:

> Hello:
>     I'd dowloaded the gromacs-3.0.5 and I am tryin to install it. In the
> ./configure step it reports that the binutils are obsolete. So I
> dowloaded the bintuils- from the installation page (by
> the way, the link to binutils- in that page is
> broken).  I installed  that binutils (./configure+make+make install)
> sucesfully.  When I tried once again to install... the same report about
> obsolecense appreared....:(
>     I downloaded the binutils-2.11.2.tar.gz from I don't remember where:
> with the same result.
>     I tried to install an older version of gromacs (3.0.3): the same
> result....
>     I updated my kernel to 2.4.17!! (it seems to have nothing todo
> but... new year-new kernel)... gromacs configure process continues
> shouting about old binutils
> the files resulting from binutils installation are:
> /usr/local/bin
> *add2line   1268133
> *ar              1188377
> *as             1735945
> *c++filt        167957
> *gasp           216155
> *gprof         1454532
> *ld               1866900
> /usr/local/lib
>   libbfd.a      3235674
> *libbfd.a              650
>   libiberty.a   518094
>   libopcodes.a 291978
> *libopcodes.la      662
>  the fft libs are already installed
> Everything seema to be OK but... don't works.
> I thank in advance for your answer.


The binutils you compiled were installed to /usr/local/bin, but the old
are probably still present in /usr/bin, which comes first in your path.

(Try 'which as' and see if it reports /usr/bin/as or /usr/local/bin/as).

There are two simple solutions - either configure the new binutils with
--prefix=/usr/bin and overwrite the old ones, or make sure /usr/local/bin
comes before /usr/bin in your path, e.g. with

setenv PATH "/usr/local/bin:$PATH"



More information about the gromacs.org_gmx-users mailing list