[gmx-users] Segmentation fault in mdrun!!!!!!!!!!!!

Karsten Suhre Karsten.Suhre at igs.cnrs-mrs.fr
Mon Feb 24 09:40:12 CET 2003

Some time ago I had a similar problem. It turned out to be unrelated to 
Gromacs. In fact, I had installed additional software on my machine that for 
some reason (that I did not further investigate in) interacted with gromacs 
(maybe setting "ulimit" or providing a command with a name is also used in 

The fix was to clean up my .bashrc (or .profile/.cshrc) and keep only 
gromacs-related stuff. 

Kind regards, Karsten.

On Sunday 23 February 2003 21:15, David wrote:
> On Sun, 2003-02-23 at 05:38, nanyu101 wrote:
> > Dear gmx-users,
> >  I don't know what happened to my system.I just try to minimize my
> > bilayer(POPC128a.PDB) downloaded from Dr.Tieleman't web.I think I'v
> > succeeded in energy minimization and tried to run some dynamics
> > simulation.But when I run, mdrun -s popcmd.tpr -o popcmd.trr -c
> > popcmd.gro
> >
> > The system told as follows. The file popcmd.tpr comes from my energy
> > minization's results.
> >
> > Back Off! I just backed up ener.edr to ./#ener.edr.1#
> > starting mdrun 'popc'
> > 20000 steps,     20.0 ps.
> >
> >
> > Back Off! I just backed up popcem.trr to ./#popcem.trr.1#
> > Segmentation fault
> >
> >
> > Would you please tell me what happened?
> What happened is a memory violation in the program. Writing an array
> outside its bounds. This can be due to two things: bugs, or large
> forces. Since you have reported problems equilibrating your system the
> latter seems most likely.

More information about the gromacs.org_gmx-users mailing list