[gmx-users] fftw 3 install error (and gromacs install) on OSX 10.2.5

Dr. Daniel James White PhD dan at chalkie.org.uk
Fri May 9 11:59:00 CEST 2003

Hi all,

Gromacs configure does not see my fftw3.h header file

Hardware PPC G4
OS, Mac OSX 10.2.5

I am trying to install fftw from the current source release so I can 
then install gromacs

I quote their down load page :

If you have a PowerPC, or possibly other CPUs with a fused-multiply add 
instruction (see the FFTW FAQ ), you should use the FMA version instead:
http: fftw-3.0-fma.tar.gz (ftp: fftw-3.0-fma.tar.gz ) (2MB)

so I got  fftw-3.0-fma.tar.gz by http

then unpacked it automatically with stuffit expander.

then in a terminal window did
./configure --enable-float --enable-type-prefix --enable-altivec
make install

all goes well, and the header file fftw3.h appears in 
and the libraries    libfftw3f.a     libfftw3f.la are in /usr/local/lib
( libfftw3.a and libfftw3.la are also there from a previous attempt)

next I downloaded the current gromacs source release gromacs-3.1.4 and 
unpacked it in /Applications/
then I did

and I get the following error
checking for sfftw.h... no
checking for fftw.h... no
configure: error: Cannot find any single precision sfftw.h or fftw.h
Do you have single precision FFTW installed? If you are using packages,
note that you also need fftw-devel to compile GROMACS. You can find the
software at www.fftw.org, and detailed instructions at www.gromacs.org.
If you compiled FFTW yourself:
Note that the default FFTW setup is double precision. Change the FFTW
configuration to single with --enable-float. If you want MPI support,
use --enable-mpi. It is a good idea to install both single & double.
If your sysadm doesn't want to install it you can do it to a location
in your home directory and provide the correct paths in the CPPFLAGS
and LDFLAGS environment variables before running configure.
That is also necessary to do if your compiler doesn't search
/usr/local/include and /usr/local/lib by default.
You can find information at www.gromacs.org, or in the INSTALL file.

so it looks like the fftw.h file isn't found....... but the header file 
make by the fftw3 build is called

so is this the problem?

why is my header file not called sfftw.h ???!!! the 
--enable-type-prefix was there!!

I tried to make a softlink in /usr/local/include   fftw.h -> fftw3.h
but still got the same error on configuring gromacs

any ideas what I am doing wrong?



Dr. Daniel James White BSc. (Hons.) PhD
Cell Biology
Department of biological and environmental science
University of Jyväskylä
+358 (0)14 260 4183 (work)
+358 (0)414740463 (mob)

dan at chalkie.org.uk
white at cc.jyu.fi

More information about the gromacs.org_gmx-users mailing list