[gmx-users] installing 3.2 with icc

Pim Schravendijk schraven at mpip-mainz.mpg.de
Tue Feb 3 22:26:01 CET 2004

After a long struggle, I managed to find the right mpich version to
install fftw-2.1.5 with (it didn't seem to work with mpich- but it
did work with mpich-1.2.4 The install that worked was with icc (don't know
if gcc also works, this was the first one I tried with 1.2.4 and was glad
enough that it worked)). 

My MPICC variable was therefore "icc" when I started installing gromacs.
configure went fine, but during make, the ./gmxlib/Makefile seems to use
the wrong compiler and fall back on gcc again, while the other directories
all compile fine, having icc as the compilername in the makefile.

schraven at bc-d1:~/bin/gromacs-3.2> make
Making all in src
make[1]: Entering directory 
make  all-recursive
make[2]: Entering directory 
Making all in gmxlib
make[3]: Entering directory 
gcc -DHAVE_CONFIG_H -I. -I. -I../../src  -I../../include 
-I/afs/@cell/@sys/soft/mpich-1.2.4/icc/include -I/usr/local/include   -O3 
-tpp6 -axK -ip  -c ./mkinl.c
gcc: unrecognized option `-tpp6'
cc1: unrecognized option `-ip'
cc1: unrecognized option `-axK'
make[3]: *** [mkinl.o] Error 1
make[3]: Leaving directory 
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory 
make[1]: *** [all] Error 2
make[1]: Leaving directory 
make: *** [all-recursive] Error 1
schraven at bc-d1:~/bin/gromacs-3.2> 

I guess I'd better try installing the whole thing with gcc again, since 
there's no real reason to use icc in the first place, but could you say if 
there's a way around this if I just want to finish this icc install?

Greetings, Pim

Pim Schravendijk - PhD Student
Max Planck Institute for Polymer Research

More information about the gromacs.org_gmx-users mailing list